How to void your ArcGIS API for JavaScript Warranty!

You may have an existing ArcGIS API 3 for JavaScript application that is running smoothly and is widely used… but you would really like to take advantage of those sweet WebScenes in version 4.

But you can’t do a full rewrite yet, or maybe you’re waiting for some features to land in version 4 before you do.

As developers, sometimes we just need to do what we need to do.

In this video, I’ll show you how you can gut the ArcGIS API for JavaScript innards and void your warranty (I kid, there’s nothing to void) and load both the 3x and 4x versions of the ArcGIS API for JavaScript inside the same application!

The best part is, WebMaps are just part of the platform, so you can load your WebMap in 3x and a 3D view in 4x and the world will be a happy place!

As your friend, I need to advise you that yes, this works. It actually works better than you might expect. I’ve just never been a fan of loading two versions of any library side-by-side.

But around here, we don’t have to play by the rules. We’re here to get shit done and make awesome apps!

If that means we do a little hax once in a while, so be it!

Be sure to like, comment, and subscribe!

Thanks!

Share on Google+1Tweet about this on TwitterShare on Facebook3Share on LinkedIn15Share on Reddit0