Tag: require

RequireJS for single-file builds: revisited.

Someone recently started a github repo using RequireJS to build their ArcGIS JavaScript applications. This piqued my interest as it’s something I had done in the past, but at some point r.js or node didn’t work properly together anymore with my build file. Rather than fuss with it, I moved on to using Grunt to…


ArcGIS JavaScript API 3.0, Dojo 1.7 and AMD Modules

Diving in For a while now, I have been keeping my JavaScript development modular by using Require.js as I have discussed before. Require.js provides AMD module loading for JavaScript projects. If you are not familiar with AMD, take a look here. Dojo 1.7 is AMD compliant and uses require/define methods to load modules. Up until…


Getting modular with the ArcGIS JavaScript API

Maybe it’s all the time I’ve spent using frameworks like Swiz and Robotlegs in my Flex development, but I usually strive to try and keep my code modular. Breaking it up into smaller manageable pieces, not┬ánecessarily so that I could reuse files but mostly for my own sanity. Have you ever caught yourself starting a…